deep web links

New Pacman Virus Attacks Apple’s Mac

In the latest hacking news, Apple Mac systems are under cyber attack that shows links to dark web criminal hackers. The analysts that discovered the arbitrary code execution on Mac databases reported that the threat actors utilize novel hardware which exploits the Pointer Validation in Apple M1 CPUs.

A pointer authentication code (PAC), is one of the main components found in a computer operating system. Its main purpose is to identify and prohibit unexpected modifications by hackers. With the faulty injection, the Pointer Accreditation safety measure that is responsible for assigning asymmetric cryptography becomes compromised, and that hack attack caused system penetration resulting in data leaks.

Cyber analytics experts at MIT’s Computer Science and Artificial Intelligence Laboratory (CSAIL), released documents that highlight the new form of cyber breach by threat actors. By gaining access to the privileged Macs filesystem, the Apple M1 CPUs access can be quite fundamental. The dark web hackers, to carry out a successful hack, will usually launch their attacks by isolating Mac’s software memory problems. Thus, amplifying the protection system into a more serious security concern.

Hackers Target MAC’s Protection

Recorded by the cyber security team as PACMAN; it utilizes the system’s software flaw (memory read/write) through a pointer authentication bypass. With this significant prime exposure, the hackers inject an arbitrary code execution into the victim’s computer pointer.

The researchers also revealed that the PAC value of the affected pointer allows the PACMAN malware to accomplish its goal. Therefore, constructing a PAC Oracle; increases the infected software’s capacity where PAC can easily evolve to match the targeted pointer. However, the main caveat is that it must accurately match the target, and if an inaccurate estimation is given, the threat actors would be unsuccessful in targeting the victim’s system.

The inaccurate estimate sent by the PAC Oracle will prevent it from crashing, and even if it survives the hack, Apple is unable to issue a future patch that will work for the hardware. To prevent hackers from triggering an assault through the vulnerability mechanism, consumers must keep their Mac software up to date with the latest version. The system must also have no defects with which hackers can execute malicious codes using PACMAN.

PACMAN is the latest exploitation method launched by criminal hackers, but it cannot breach a computer system. However, hacking groups have created new software components that can breach PC systems through malicious command injections.

And while it cannot breach a system on its own; it can create damage through a kernel panic that can crash the entire database. PACMAN’s main purpose is to prevent a systemic crash and delete all hacking traces from computer logs.

Apple has been made aware of the problem, since 2021, according to the CSAIL cyber analysts. However, the company issued a statement revealing that after analyzing the PACMAN code hack; it found that the current hacking threat posed no imminent danger to Mac consumers.

Leave a Reply

Your email address will not be published.